Resolved
Our marketing website is now back online. The issue was caused by an outage on Webflow’s side, which has since been resolved. Thank you for your patience.
Monitoring
The website www.weglot.com is partially available again.
Investigating
Access to www.weglot.com is currently unavailable. This is due to a third-party service provider outage.
None of our translation services or access to our application are affected.